Reports of increased latency from the Western Europe Region.
Incident Report for Onshape
Resolved
This incident has been resolved.
Posted about 1 year ago. Nov 09, 2016 - 11:08 EST
Investigating
We are investigating reports of increased latency in the Western Europe Region.
Posted about 1 year ago. Nov 09, 2016 - 09:35 EST