Degraded Performance
Incident Report for Onshape
Resolved
The underlying issue to the performance problems has been addressed, and performance has returned to normal.
Posted 6 months ago. May 11, 2017 - 16:01 EDT
Investigating
We are aware of performance problems, and are working to correct them,
Posted 6 months ago. May 11, 2017 - 15:55 EDT