Degraded performance in our North America region
Incident Report for Onshape
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 27, 2017 - 10:59 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Mar 27, 2017 - 10:42 EDT
Investigating
We are currently investigating degraded performance on a subset of documents in our North America region.
Posted 4 months ago. Mar 27, 2017 - 10:19 EDT