Degraded performance in our North America region
Incident Report for Onshape
Resolved
We have resolved the issue which was causing degraded performance in North America.
Posted 12 months ago. Feb 06, 2017 - 16:39 EST
Investigating
We are currently investigating degraded performance in our North America region
Posted 12 months ago. Feb 06, 2017 - 15:34 EST