Performance slowdowns opening documents

Incident Report for Onshape

Resolved

Our monitoring shows that performance has improved with the addition of more resources. We will continue to investigate for possible causes for this momentary performance degradation.
Posted Nov 18, 2020 - 11:00 EST

Investigating

We are currently investigating this issue.
Posted Nov 18, 2020 - 10:50 EST
This incident affected: Onshape CAD Service (https://cad.onshape.com) (North America).