Unable to connect in US Region.
Incident Report for Onshape
Resolved
This incident has been resolved.
Posted 6 months ago. Mar 22, 2019 - 16:29 EDT
Investigating
We are currently investigating an issue with connecting to cad.onshape.com in US Region.
Posted 6 months ago. Mar 22, 2019 - 16:27 EDT
This incident affected: Onshape CAD Service (https://cad.onshape.com) (North America).