Account signups are not working

Incident Report for Onshape

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 12:59 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 08, 2025 - 12:58 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 08, 2025 - 10:54 EDT

Investigating

Account signups are unavailable at this time. We are working to resolve the issue.
Posted Oct 08, 2025 - 09:39 EDT
This incident affected: Company Website (https://www.onshape.com).