Customers experiencing issues updating payment method
Incident Report for Onshape
Resolved
This incident has been resolved.
Posted Jul 14, 2021 - 11:03 EDT
Investigating
Customers may experience difficulty updating their payment method at https://onshape.secure.force.com - we are aware of the problem and are working on a solution
Posted Jul 01, 2021 - 14:49 EDT
This incident affected: Company Website (https://www.onshape.com).