Documents list page is very slow to load.
Incident Report for Onshape
Resolved
This incident has been resolved.
Posted Nov 28, 2023 - 19:13 EST
Investigating
We are seeing the documents list page load very slowly. We are investingating.
Posted Nov 28, 2023 - 18:50 EST
This incident affected: Onshape CAD Service (https://cad.onshape.com) (North America, Western Europe, Southeast Asia, Australia, Northeast Asia).