Performance issues in North America and Western Europe regions

Incident Report for Onshape

Resolved

This incident has been resolved.
Posted May 24, 2026 - 15:52 EDT

Investigating

Our automated systems are reporting performance issues in the North America and Western Europe.
Posted May 24, 2026 - 15:33 EDT
This incident affected: Onshape CAD Service (https://cad.onshape.com) (North America, Western Europe).