Support ticket submission is silently failing
Incident Report for Onshape
Resolved
This incident has been resolved.
Posted Mar 31, 2022 - 17:10 EDT
Identified
Our in-product support ticket system is down. Support tickets that are filed are currently being lost. We are working on restoring this system as quickly as possible.

For urgent support issues, please send mail to support@onshape.com

We apologize for the inconvenience.
Posted Mar 31, 2022 - 17:06 EDT
This incident affected: Onshape Support Service (https://onshape.zendesk.com).