Thumbnail generation delayed

Incident Report for Onshape

Resolved

We have resolved the incident and thumbnail generation has returned to normal. All backlogged thumbnail generation requests have been processed.
Posted Sep 03, 2025 - 14:46 EDT

Identified

We have identified the issue and the thumbnail processing rate has increased. We are monitoring as the system processes the thumbnail generation backlog.
Posted Sep 03, 2025 - 08:13 EDT

Investigating

We're currently investigating delayed thumbnail generation affecting users in North America. Our team is actively working to identify the root cause and restore normal performance as quickly as possible.
Posted Sep 03, 2025 - 04:32 EDT
This incident affected: Onshape CAD Service (https://cad.onshape.com) (North America).