Unable to open documents in the North America region
Incident Report for Onshape
Resolved
This incident has been resolved.
Posted Mar 25, 2020 - 00:08 EDT
Investigating
Automated systems are reporting problems with opening documents in the North America region. We are currently investigating.
Posted Mar 24, 2020 - 23:20 EDT
This incident affected: Onshape CAD Service (https://cad.onshape.com) (North America).