INTERNAL ERROR on regeneration of some part studios
Incident Report for Onshape
Resolved
This incident has been resolved. We have deployed a fix for the problem and cleared cache (temporary state) for all documents that experienced errors. If you are still seeing problems with part studio regeneration, please contact support.
Posted Jun 22, 2021 - 22:45 EDT
Identified
Engineering has identified the problem and a fix is building now. We will be updating Onshape with the fix as soon as the change passes our internal software quality processes. This is expected within the next 4 hours.
Posted Jun 22, 2021 - 14:06 EDT
Investigating
Our support team is receiving reports from some small number of customers that are seeing the error:

INTERNAL ERROR. If the problem persists, please contact support.
Empty temporary stack when trying to pop temporary R.

...during a regeneration.

Our engineering team is investigating this as a top priority.
Posted Jun 22, 2021 - 06:33 EDT
This incident affected: Onshape CAD Service (https://cad.onshape.com) (North America, Western Europe, Southeast Asia, Australia, Northeast Asia).