Unable to open documents in US-West region.

Incident Report for Onshape

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 14:50 EDT

Investigating

We are receiving reports of documents being slow or unable to open in US-West region. We are investigating and will provide an update within 30 minutes.
Posted Apr 20, 2026 - 14:09 EDT
This incident affected: Onshape CAD Service (https://cad.onshape.com) (North America).