Failure to open documents
Incident Report for Onshape
Resolved
We have again resolved the problem. We are working with our engineering teams to understand the issue and prevent it in the future. We apologize for the lost productivity.
Posted 11 months ago. Sep 18, 2018 - 07:41 EDT
Investigating
We are again seeing problems opening some documents in the North America region. We are investigating.
Posted 11 months ago. Sep 18, 2018 - 07:20 EDT
This incident affected: Onshape CAD Service (https://cad.onshape.com) (North America).