Degraded performance for Onshape services in US-West

Incident Report for Onshape

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 14:34 EDT

Monitoring

We’re currently experiencing degraded performance issues within US-West. Our team is currently working to restore normal performance levels and will provide next update in 30 minutes.
Posted Mar 18, 2026 - 14:12 EDT
This incident affected: Onshape CAD Service (https://cad.onshape.com) (North America).