www.onshape.com is down

Incident Report for Onshape

Resolved

This incident has been resolved.
Posted May 12, 2025 - 21:33 EDT

Identified

www.onshape.com is not responding. We are working with our vendor to resolve the situation.

You can go to https://cad.onshape.com or your enterprise domain URL to use the Onshape CAD service.
Posted May 12, 2025 - 19:53 EDT
This incident affected: Company Website (https://www.onshape.com).