Unable to open documents in all regions

Incident Report for Onshape

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 14:03 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2026 - 13:48 EDT

Update

We are continuing to investigate this issue.
Posted Mar 18, 2026 - 12:22 EDT

Investigating

We are receiving reports of documents being slow or unable to open in all regions. We are investigating and will provide an update within 30 minutes.
Posted Mar 18, 2026 - 12:20 EDT
This incident affected: Onshape CAD Service (https://cad.onshape.com) (North America, Western Europe, Southeast Asia, Australia, Northeast Asia).